[Решено] Драйвер видеокарты АМД.  

  RSS

Sergio
(@sergio)
Новичок
Присоединился:1 год  назад
Сообщения: 1
03/01/2017 12:34 дп  

Здравствуйте. Являюсь "счастливым" обладателем видокарты AMD Radeon HD 6950. Но вот драйвер на нее не найду, в менеджере драйверов только intel-microcode. На сайте АМД  есть поддержка только старых версий линукс. Хотелось бы запускать еще и игры кроме браузера. Кстати стоит linux mint 18.1 ядро 4.4.0-53. Помогите, кто сталкивался с подобной проблемой.


ОтветитьЦитата
fox
 fox
(@admin)
Всем здесь управляю я Admin
Присоединился:1 год  назад
Сообщения: 328
03/01/2017 8:24 дп  

Похоже что пора сменить видеокарту.

Пользуюсь Ubuntu 16.04/17.10, Kubuntu 17.10 а также KDE NEON


ОтветитьЦитата
fox
 fox
(@admin)
Всем здесь управляю я Admin
Присоединился:1 год  назад
Сообщения: 328
03/01/2017 10:11 дп  

Но, если посмотреть на официальный сайт AMD, то там доступны драйвера для Ubuntu 14.04 с поддержкой вашей видеокарты.

И у меня вопрос - Так почему-бы не использовать Linux mint 17? и играть нормально в игры.

Пользуюсь Ubuntu 16.04/17.10, Kubuntu 17.10 а также KDE NEON


ОтветитьЦитата
Sergio
(@sergio)
Новичок
Присоединился:1 год  назад
Сообщения: 1
03/01/2017 12:21 пп  

Хотелось конечно иметь новейшую систему. Если я поставлю Ubuntu 14.04 мне обязательно форматировать /home? Или установленные программы некорректно отобразятся?


ОтветитьЦитата
fox
 fox
(@admin)
Всем здесь управляю я Admin
Присоединился:1 год  назад
Сообщения: 328
03/01/2017 12:23 пп  

Желательно отформатировать, так как это совсем другая система.

Пользуюсь Ubuntu 16.04/17.10, Kubuntu 17.10 а также KDE NEON


ОтветитьЦитата
Sergio
(@sergio)
Новичок
Присоединился:1 год  назад
Сообщения: 1
03/01/2017 12:47 пп  

Спасибо за ответы, можно закрывать.


ОтветитьЦитата
mook
 mook
(@mook)
Активный участник
Присоединился:1 год  назад
Сообщения: 12
03/01/2017 5:39 пп  

16.04 пишут полная поддержка

https://help.ubuntu.com/community/RadeonDriver


ОтветитьЦитата
fox
 fox
(@admin)
Всем здесь управляю я Admin
Присоединился:1 год  назад
Сообщения: 328
03/01/2017 7:12 пп  

Да, как пишут

The Radeon driver is already pre-installed in Ubuntu

Radeon драйвер уже установлен в систему, а человек пишет что у него его нету, хотя можно попробовать установить fglrx, вот отсюда

Пользуюсь Ubuntu 16.04/17.10, Kubuntu 17.10 а также KDE NEON


ОтветитьЦитата
Grombixalo
(@grombixalo)
Новичок
Присоединился:1 год  назад
Сообщения: 1
15/01/2017 9:14 пп  
От: fox

 

Да, как пишут

The Radeon driver is already pre-installed in Ubuntu

Radeon драйвер уже установлен в систему, а человек пишет что у него его нету, хотя можно попробовать установить fglrx, вот отсюда

   

Не знаю, что стоит в бубунте, но в минте 18,1 стоит свободный. Любая попытка запустить что-либо тяжелое превращается в танцы с бубнами. Да - танчики и ракаблики идут, но вот допустим "СТИМ" требует препроитарный драйвер.  Установка fglrx  крашить иксы при перезагрузке. Помогает только загрузка через восстановление системы в "грабе" и потом через "миднайт командер" (кому что нравится) искать /usr/share/ati и запущать - "uninstall-amd.sh". Тогда иксы возвращаются и все работает.

Попытка установить проприетарный драйвер на "Mint 18.1" отсюда  http://support.amd.com/en-us/kb-articles/Pages/AMDGPU-PRO-Driver-for-Linux-Release-Notes.aspx наталкивается на совершенно непонятную проблему. При установке через консоль, согласно инструкции, пишет - "Unsuported OS". Это как? Драйвер для Ubuntu 16.04, минт основана на бубунту 16,04 и неподдерживаемая операционная система? Или я чего то не понимаю? 

 


Nikolay лайков
ОтветитьЦитата
fox
 fox
(@admin)
Всем здесь управляю я Admin
Присоединился:1 год  назад
Сообщения: 328
15/01/2017 9:44 пп  

Я ничем не могу помочь, так как у меня на двух компьютерах Nvidia.

Пользуюсь Ubuntu 16.04/17.10, Kubuntu 17.10 а также KDE NEON


ОтветитьЦитата
djigit_91
(@abu)
Старожил
Присоединился:1 год  назад
Сообщения: 111
15/01/2017 10:31 пп  

у меня тоже нвидиа


ОтветитьЦитата
Sergio
(@sergio)
Новичок
Присоединился:1 год  назад
Сообщения: 1
16/01/2017 12:14 дп  

Когда у меня стояла нвидиа я тоже не задавался вопросом драйвера. Но после того как она сгорела пришлось брать то что есть. Но теперь я знаю что следующая будет только нвидиа.


ОтветитьЦитата
Nikolay
(@nikolay)
Новичок
Присоединился:3 месяца  назад
Сообщения: 1
08/11/2017 10:50 дп  
От: Grombixalo
От: fox

 

Да, как пишут

The Radeon driver is already pre-installed in Ubuntu

Radeon драйвер уже установлен в систему, а человек пишет что у него его нету, хотя можно попробовать установить fglrx, вот <a href=" удаленная ссылка " target="true">отсюда

   

Не знаю, что стоит в бубунте, но в минте 18,1 стоит свободный. Любая попытка запустить что-либо тяжелое превращается в танцы с бубнами. Да - танчики и ракаблики идут, но вот допустим "СТИМ" требует препроитарный драйвер.  Установка fglrx  крашить иксы при перезагрузке. Помогает только загрузка через восстановление системы в "грабе" и потом через "миднайт командер" (кому что нравится) искать /usr/share/ati и запущать - " удаленная ссылка ". Тогда иксы возвращаются и все работает.

Попытка установить проприетарный драйвер на "Mint удаленная ссылка " отсюда  удаленная ссылка наталкивается на совершенно непонятную проблему. При установке через консоль, согласно инструкции, пишет - "Unsuported OS". Это как? Драйвер для Ubuntu удаленная ссылка , минт основана на бубунту 16,04 и неподдерживаемая операционная система? Или я чего то не понимаю? 

 

Такая же проблема, при установке через консоль, согласно инструкции, пишет - "Unsuported OS", кто знает как решить подскажите.


ОтветитьЦитата
fox
 fox
(@admin)
Всем здесь управляю я Admin
Присоединился:1 год  назад
Сообщения: 328
08/11/2017 11:06 дп  

А в диспетчере драйверов что пишет? Там есть вообще какие-то предложения установки драйвера?

Извините за вопрос, но я понятия не имею как там c AMD, и например если я использую Nvidia, то в диспетчере драйверов предлагается стабильная версия драйвера Nvidia. 

Пользуюсь Ubuntu 16.04/17.10, Kubuntu 17.10 а также KDE NEON


ОтветитьЦитата
fox
 fox
(@admin)
Всем здесь управляю я Admin
Присоединился:1 год  назад
Сообщения: 328
08/11/2017 11:30 дп  

Инструкция актуальна для Linux Mint 18.X с ядром от 4.4.0-53 до 4.10.0-32

Установка 

1. добавим репозиторий с необходимыми пакетами

echo "deb  https://linuxmint.com.ru/repo/xenial/  /" | sudo tee -a /etc/apt/sources.list

wget --quiet https://linuxmint.com.ru/repo/xenial/lmcomru-pubkey; sudo apt-key add lmcomru-pubkey
apt update

2. Приведение версий xorg

apt install xserver-xorg-core=2:1.17.3-2ubuntu4 xserver-common=2:1.17.3-2ubuntu4 xserver-xorg-input-evdev=1:2.9.2-1ubuntu1 xserver-xorg-input-synaptics=1.8.2-1ubuntu2 xserver-xorg-input-vmmouse=1:13.1.0-1ubuntu1 xserver-xorg-input-wacom=1:0.32.0-0ubuntu2 xserver-xorg-video-intel=2:2.99.917+git20160218-1ubuntu2 xserver-xorg-video-radeon=1:7.6.1-1ubuntu1 lib32gcc1 libc6 libc6-dbg libc6-i386 

3. Установка драйвера:

Для пользователей 18 (Sarah) и 18.1 (Serena)

apt install fglrx fglrx-dev fglrx-core fglrx-amdcccle

Для пользователей 18.2 (Sonya)

Качаем и устанавливаем следующие 4 пакета для соответсвующей версии ядра (uname -r):

Для 4.8

для 4.10

Для установки просто переходим в папку со скачанными файлами и выполняем 

sudo dpkg -i fglrx*.deb

4. обновление конфигурации и фиксация версии xorg

sudo aticonfig --initial
sudo apt hold xserver-xorg-core xserver-common fglrx-core

Примечание
Для пользователей Cinnamon - важно добавить в файл /etc/environment следующие строки:

export COGL_DRIVER=gl
export COGL_OVERRIDE_GL_VERSION=1.4
export COGL_RENDERER=GLX

Иначе вместо радостей прилетит черный экран.

Финал
Перезагружаем систему и радуемся новому драйверу

Инструкция была взята с форума Linux mint - linuxmint.com.ru

Отредактировано:3 месяца  назад

Пользуюсь Ubuntu 16.04/17.10, Kubuntu 17.10 а также KDE NEON


AraksTS лайков
ОтветитьЦитата
  
Работает

Пожалуйста, Вход или Зарегистрироваться